Extras

Crypt Plugin

The original release of the crypt plugin has been modified to operate in a manner that's compatible with tinycrypt. It still uses ARC4 for en/de-cryption, unlike the current release of the crypt plugin. This plugin may be built and installed alongside the 'official' en/decryption plugin. Place the plugin file, and the minilzo file (see below) into the plugins directory in your source-code tree, or place these filed elsewhere and link the files into the plugins dir. Then re-build.

minilzo compression code is needed to make this plugin work. For convenience, v.2.03 of that code is bundled here (23kB).

Archive Unpacker

This archive (2kB) provides a bash script, and brief usage notes, for uppacking several sorts of archive into a subdir in the inactive pane. Similar in effect to the unpack plugin, but not using a temp dir for unpacking.

Library for Thumbnails Plugin

This archive (110kB) provides a version of the GIMP thumbnails library that (unlike the original) works with multiple users and/or multiple threads, and doesn't crash when re-used. You will need to run the included autogen.sh script before the usual build sequence.

This shared library is badged as 'libthumbs' and may be installed in parallel with the standard libgimpthumb.

Use of libthumbs is optional (via a Make parameter) for the thumbnails plugin. If not used, relevant code is built into the plugin, instead. However, for versions < 0.7.5, the built-in code includes static data for a GObject-class, so you really must use the library if: multiple instances of emelFM2 are ever to be open simultaneously, and more than one of those instances has an open thumbs dialog when the instance is terminated and the opened instances are not terminated in LIFO order. Probably not a big risk.

Patches

To update your emelfm2 using one of these patches:

1. De-compress the patch ('bzip2 -d patchfile-name') into the top-level directory where the "base" emelfm2 source-code is installed (where there is, for example, the file Makefile). 2. Apply the patch using 'patch -p0 < uncompressed-patchfile-name' 3. Run 'make clean' 4. Rebuild emelfm2 as you normally would 5. If you use a translation file (currently pl, ru, de, fr or ja), run 'make i18n' and (as root) 'make install_i18n' - because the patches do not include updates to pot & po files

Several patches for gtk-spell attachment:gtkspell-2.0.11-patches-V2.tar.bz2 (4kB) Some of them are needed if spell-checking is enabled in emelFM2's internal editor (version >= 0.3.3). For convenience, a patch to enable the enchant speller interface is included. Gtk-spell-2.0.14 and later do not need to be patched.

Icons

Custom icons as supplied with emelfm2 v.0.6.0 - but in SVG format - are available in this archive (69 kb).

Alternate (and older) custom icons conformed to tango style guide: scalable (74 kB) or 48X48 (109 kB)

Here are some packages for different distributions contributed by users.

RPM

openSUSE

openSUSE

Fedora Core

fedora-extras 3, 4, devel/5

DEB

Ubuntu

TGZ

Zenwalk Linux

Zenwalk unofficial packages (Those packages should work on most other Slackware based distro's too)

Attachments